Downtime Detected
Incident Report for Pirate Ship
Resolved
The ship is up and running again!
Posted Nov 29, 2023 - 11:40 MST
Update
UPS label purchases should work again.
Posted Nov 29, 2023 - 11:32 MST
Monitoring
We deployed a fix and are monitoring.
Posted Nov 29, 2023 - 11:24 MST
Identified
We're working on isolating the issue so our platform is not affected and USPS labels can be purchased as usually.
Posted Nov 29, 2023 - 11:15 MST
Investigating
UPS is having issues with their systems. Subscribe to receive updates as we work to fix this as quickly as we can. We know how important it is for you to be able to ship right now—we're sorry for the trouble Captain!
Posted Nov 29, 2023 - 11:13 MST
This incident affected: Pirate Ship App (ship.pirateship.com) and Shipment & Pickup Processing (UPS Shipments, Pickups and Delivery Estimates).