USPS SCAN Forms and Refunds outage

Incident Report for Pirate Ship

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 12:57 MDT

Monitoring

The API we use to communicate with USPS is having trouble right now. Creation of SCAN Forms and Shipment Refunds are currently not fully operational. Creating Labels is still working. We'll monitor the situation and update once we know more.
Posted Jun 03, 2026 - 11:42 MDT
This incident affected: Pirate Ship App (ship.pirateship.com) and Shipment & Pickup Processing (USPS Shipments).