USPS Return Label Purchasing Temporarily Unavailable

Incident Report for Pirate Ship

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 13:00 MDT

Identified

We are currently investigating an issue affecting the purchase of USPS Return labels. All other label types continue to function normally. We are actively working with USPS to resolve this and expect a fix later today.
Posted Aug 18, 2026 - 11:59 MDT
This incident affected: Pirate Ship App (ship.pirateship.com) and Shipment & Pickup Processing (USPS Shipments).