UPS Purchase API Outage
Incident Report for Pirate Ship
Resolved
This incident has been resolved.
Posted May 07, 2024 - 10:23 MDT
Monitoring
A misconfiguration caused the API requests for purchasing UPS labels and scheduling UPS pickups to fail. A fix has been applied and endpoints are up and running again. We are continuing to monitor API requests to make sure the issue is completely resolved.
Posted May 07, 2024 - 08:47 MDT
Investigating
The API we use to communicate with UPS to buy labels is having issues. We're working with our partners to help them fix this issue as quickly as possible, and will keep you updated.
Posted May 07, 2024 - 08:05 MDT
This incident affected: Pirate Ship App (ship.pirateship.com) and Shipment & Pickup Processing (UPS Shipments, Pickups and Delivery Estimates).