USPS API Outage

Incident Report for Pirate Ship

Resolved

This incident has been resolved.
Posted May 30, 2024 - 18:56 MDT

Monitoring

The API we use to communicate with USPS has been having intermittent connection issues. If you receive an error message, we suggest retrying, as we're seeing the connection issues improving. We're working with our partners to help them fix this issue as quickly as possible, and will keep you updated.
Posted May 30, 2024 - 18:43 MDT
This incident affected: Pirate Ship App (ship.pirateship.com) and Shipment & Pickup Processing (USPS Pickups & Delivery Estimates).