UPS Shipping Outage
Incident Report for Pirate Ship
Resolved
We're do not see any more issues on our end and UPS Rating and Shipping has arrived in calm waters. Our overall site performance has stabilized. Thanks for your patience matey! You should be able to get back to your shipping. If you have any questions or concerns, just chat or email our support—we're here for ya!
Posted May 17, 2024 - 13:52 MDT
Monitoring
We received confirmation from our partners at UPS, that their services are currently degraded.
Posted May 17, 2024 - 13:26 MDT
Investigating
We're aware there's an issue and our team is currently investigating what's gone wrong. Subscribe to receive updates as we work to fix this as quickly as we can. We know how important it is for you to be able to ship right now—we're sorry for the trouble Captain!
Posted May 17, 2024 - 13:15 MDT
This incident affected: Pirate Ship App (ship.pirateship.com).