UPS account creation issues

Incident Report for Pirate Ship

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 17:46 MST

Monitoring

Customers should be able to proceed accepting the UPS terms and conditions screen again and be able to purchase labels. We are continuing to monitor the endpoint to make sure everything is running smoothly!
Posted Nov 24, 2025 - 17:35 MST

Identified

We're aware of issues purchasing UPS labels in case you have not shipped with UPS before or not recently. You may be unable to continue on the terms & conditions dialog that pops up when buying a label while the the issue remains. Our crew is doing everything then can to get it shipshape again. We'll keep you updated here. Sorry for the trouble Captain!
Posted Nov 24, 2025 - 16:23 MST
This incident affected: Shipment & Pickup Processing (UPS Shipments, Pickups and Delivery Estimates).