Emails Delayed

Incident Report for Pirate Ship

Resolved

This incident has been resolved.
Posted Sep 06, 2025 - 14:13 MDT

Investigating

We are currently experiencing an issue with our mail server, which is affecting the delivery of transactional emails from our application.
Our team is currently investigating what's gone wrong. Subscribe to receive updates as we work to fix this as quickly as we can. We know how important it is for you to be able to ship right now—we're sorry for the trouble Captain!
Posted Sep 06, 2025 - 11:06 MDT
This incident affected: Pirate Ship App (ship.pirateship.com).