Simple Export Rate can not be purchased
Incident Report for Pirate Ship
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 10:29 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2024 - 10:18 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 11, 2024 - 10:04 MDT
Investigating
We're aware there's an issue and our team is currently investigating what's gone wrong. Subscribe to receive updates as we work to fix this as quickly as we can. We know how important it is for you to be able to ship right now—we're sorry for the trouble Captain!
Posted Apr 11, 2024 - 10:03 MDT
This incident affected: Pirate Ship App (ship.pirateship.com) and Shipment & Pickup Processing (Simple Export Rate Shipments (Asendia)).