Payment Gateway Outage (PayPal and Credit Card)
Incident Report for Pirate Ship
Resolved
All payment gateways are back online and we've confirmed the issue has been fully resolved. Thanks for your patience matey! You should be able to get back to your shipping. If you have any questions or concerns, just chat or email our support—we're here for ya!
Posted Sep 20, 2023 - 17:20 MDT
Update
We're communicating with our Credit Card payment partner, PayPal is fully operational at this time.
Posted Sep 20, 2023 - 14:00 MDT
Investigating
We're aware there's an issue and our team is currently investigating what's gone wrong. Subscribe to receive updates as we work to fix this as quickly as we can. We know how important it is for you to be able to ship right now—we're sorry for the trouble Captain!
Posted Sep 20, 2023 - 13:37 MDT
This incident affected: Pirate Ship App (ship.pirateship.com).