UPS Outage

Incident Report for Pirate Ship

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 16:24 MDT

Monitoring

The API issues previously affecting UPS have been resolved, and purchasing UPS labels is now possible again. We will continue to monitor the situation closely to ensure full stability.
Posted Jun 11, 2026 - 15:45 MDT

Investigating

We're aware there's an issue with UPS and our team is currently investigating what's gone wrong. Subscribe to receive updates as we work to fix this as quickly as we can. We know how important it is for you to be able to ship right now—we're sorry for the trouble Captain!
Posted Jun 11, 2026 - 14:50 MDT
This incident affected: Pirate Ship App (ship.pirateship.com) and Shipment & Pickup Processing (UPS Shipments, Pickups and Delivery Estimates).