Elevated errors for International USPS Labels

Incident Report for Pirate Ship

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 11:44 MDT

Monitoring

A fix has been rolled out and we don't see errors anymore. We will continue monitoring.
Posted Jun 30, 2026 - 10:55 MDT

Identified

A fix for the issue is currently being tested and will be rolled out once verified.
Posted Jun 30, 2026 - 10:12 MDT

Investigating

We're aware there's an issue with creating USPS labels for international shipments right now. Subscribe to receive updates as we work to fix this as quickly as we can. We know how important it is for you to be able to ship right now—we're sorry for the trouble Captain!
Posted Jun 30, 2026 - 06:59 MDT
This incident affected: Pirate Ship App (ship.pirateship.com) and Shipment & Pickup Processing (USPS Shipments).